Clever Logins Failing
Incident Report for Thrivist
Resolved
The Clever login issue has been resolved.
Posted 4 months ago. May 31, 2019 - 10:42 CDT
Investigating
We are receiving reports that Clever logins to Curve are not functioning. Currently investigating.
Posted 4 months ago. May 31, 2019 - 09:04 CDT
This incident affected: Curve LMS.